Fleetworthy

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Toll Portal in prolonged maintenance mode
Resolved·Full outage

The incident affecting service has been resolved. Normal operation has been fully restored. Thank you for your patience and understanding during this time.

Thu, Feb 19, 2026, 02:58 PM
(4 months ago)
·
Affected components
Feb 19, 2026, 01:33 PM
02:58 PM
Updates

Resolved

The incident affecting service has been resolved. Normal operation has been fully restored. Thank you for your patience and understanding during this time.

Thu, Feb 19, 2026, 02:58 PM

Investigating

Dear Fleetworthy Customers,

We are currently investigating reports of a disruption to service due to redirection from Toll Portal to maintenance page. Our engineering and operations teams are actively working on the condition. Further updates will be provided as more information becomes available.

Thu, Feb 19, 2026, 01:33 PM(1 hour earlier)