Resolved
The incident affecting eFleet form services has been resolved. Normal operation has been fully restored. Thank you for your patience and understanding during this time.
Monitoring
A fix has been implemented, and we are closely monitoring the results. We will confirm resolution once the issue has been fully validated.
Identified
We have identified the underlying cause of the issue affecting the delivery of service. A fix is being developed and implemented. We will continue to share updates until the issue is resolved.
Investigating
Dear Fleetworthy Customers,
We are currently investigating reports of a disruption to service for eFleet Forms. Our engineering and operations teams are actively working to identify the cause. Further updates will be provided as more information becomes available.